SQLiteDb.OpenParams Interface
Parameters for opening an existing SQLiteDb
Extends
Properties
Name | Type | Description | |
---|---|---|---|
openMode | OpenMode | use OpenMode.ReadWrite to open the file with write access |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
defaultTxn Inherited | "0" | "1" | "2" | "3" | SQLiteDb.OpenOrCreateParams | the default transaction mode |
immutable Inherited | boolean | undefined | SQLiteDb.OpenOrCreateParams | |
queryParam Inherited | string | undefined | SQLiteDb.OpenOrCreateParams | see query parameters from 'URI Filenames' in https://www.sqlite.org/c3ref/open.html |
rawSQLite Inherited | boolean | undefined | SQLiteDb.OpenOrCreateParams | If true, do not require that the be_Prop table exist |
skipFileCheck Inherited | boolean | undefined | SQLiteDb.OpenOrCreateParams | Do not attempt to verify that the file is a valid sQLite file before opening. |
Defined in
- core/backend/src/SQLiteDb.ts Line 474
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.