SQLiteDb.OpenOrCreateParams Interface
parameters common to opening or creating a new SQLiteDb
Properties
Name | Type | Description | |
---|---|---|---|
defaultTxn | "0" | "1" | "2" | "3" | the default transaction mode | |
immutable | boolean | undefined | ||
queryParam | string | undefined | see query parameters from 'URI Filenames' in https://www.sqlite.org/c3ref/open.html | |
rawSQLite | boolean | undefined | If true, do not require that the be_Prop table exist |
|
skipFileCheck | boolean | undefined | Do not attempt to verify that the file is a valid sQLite file before opening. |
Defined in
- core/backend/src/SQLiteDb.ts Line 458
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.