_initializeDb MethodProtected Static
Initialize a cloud container to hold VersionedSqliteDbs. The container must first be created by CloudSqlite.DbAccess.createBlobContainer. This function creates and uploads an empty database into the container.
_initializeDb(args: { blockSize?: "4M" | "64K", dbName: string, dbType: , props: CloudSqlite.ContainerProps }): Promise<void>
@note this deletes any existing content in the container.
Parameter | Type | Description |
---|---|---|
args | { blockSize?: "4M" | "64K", dbName: string, dbType: , props: CloudSqlite.ContainerProps } |
Returns - Promise
Defined in
- core/backend/src/CloudSqlite.ts Line 893
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.