CloudSqlite.createCloudContainer Function
Create a new CloudContainer from a ContainerAccessProps. For non-public containers, a valid accessToken must be provided before the container can be used (e.g. via requestToken).
createCloudContainer(args: CloudSqlite.ContainerAccessProps & { accessLevel?: BlobContainer.RequestAccessLevel, tokenFn?: (args: CloudSqlite.RequestTokenArgs) => Promise<string> }): CloudSqlite.CloudContainer
@note After the container is successfully connected to a CloudCache, it will begin auto-refreshing its accessToken every tokenRefreshSeconds
seconds (default is 1 hour)
until it is disconnected. However, if the container is public, or if tokenRefreshSeconds
is <=0, auto-refresh is not enabled.
Parameter | Type | Description |
---|---|---|
args | CloudSqlite.ContainerAccessProps & { accessLevel?: BlobContainer.RequestAccessLevel, tokenFn?: (args: CloudSqlite.RequestTokenArgs) => Promise<string> } |
Returns - CloudSqlite.CloudContainer
Defined in
- core/backend/src/CloudSqlite.ts Line 64
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.