CloudSqlite.cleanDeletedBlocks Function
Clean any unused deleted blocks from cloud storage. Unused deleted blocks can accumulate in cloud storage in a couple of ways:
- When a database is updated, a subset of its blocks are replaced by new versions, sometimes leaving the originals unused.
- A database is deleted with CloudContainer.deleteDatabase In both cases, the blocks are not deleted immediately. Instead, they are scheduled for deletion at some later time. Calling this method deletes all blocks in the cloud container for which the scheduled deletion time has passed.
cleanDeletedBlocks(container: CloudSqlite.CloudContainer, options: CloudSqlite.CleanDeletedBlocksOptions): Promise<void>
@see CleanDeletedBlocksOptions
Parameter | Type | Description |
---|---|---|
container | CloudSqlite.CloudContainer | the CloudContainer to be cleaned. Must be connected and hold the write lock. |
options | CloudSqlite.CleanDeletedBlocksOptions | options for the cleanup operation. |
Returns - Promise
Defined in
- core/backend/src/CloudSqlite.ts Line 594
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.