CloudSqlite.CleanDeletedBlocksOptions Interface

Properties

Name Type Description
debugLogging boolean | undefined if enabled, outputs verbose logs about the cleanup process.  
findOrphanedBlocks boolean | undefined If true, iterates over all blobs in the cloud container to add blocks that are 'orphaned' to the delete list in the manifest.  
nSeconds number | undefined Any block that was marked as unused before this number of seconds ago will be deleted.  
onProgress (nDeleted: number, nTotalToDelete: number) => Promise<number> | undefined a user-supplied progress function called during the cleanup operation.  

Defined in

Last Updated: 14 November, 2024