upgradeCustomAttributesToEC3 Function
Converts schema metadata to EC3 concepts by traversing custom attributes of the supplied schema and calling converters based on schemaName:customAttributeName
upgradeCustomAttributesToEC3(xmlSchemas: string[], schemaContext?: ECSchemaXmlContext): string[]
@returns EC3.2 Xml ECSchema(s) with converted custom attributes.
@throws IModelError if there is a problem converting the custom attributes of a schema.
Parameter | Type | Description |
---|---|---|
xmlSchemas | string[] | The ECSchema Xml string(s). |
schemaContext | ECSchemaXmlContext |
Returns - string[]
EC3.2 Xml ECSchema(s) with converted custom attributes.
Defined in
- core/backend/src/SchemaUtils.ts Line 35
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.