is MethodStatic
return whether this Entity class is a subclass of another Entity class
is(otherClass: ): boolean
@note the subclass-ness is checked according to JavaScript inheritance, to check the underlying raw EC class's inheritance, you can use ECClass.is
@note this should have a type of is<T extends typeof Entity>(otherClass: T): this is T
but can't because of
typescript's restriction on the this
type in static methods
Parameter | Type | Description |
---|---|---|
otherClass |
Returns - boolean
Defined in
- core/backend/src/Entity.ts Line 104
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.