convertEC2SchemasToEC3Schemas Function
Converts EC2 Xml ECSchema(s). On success, the EC2 Xml schemas
are converted into EC3.2 Xml schemas
.
convertEC2SchemasToEC3Schemas(ec2XmlSchemas: string[], schemaContext?: ECSchemaXmlContext): string[]
@returns EC3.2 Xml ECSchema(s).
@throws IModelError if there is a problem converting the EC2 schemas.
Parameter | Type | Description |
---|---|---|
ec2XmlSchemas | string[] | The EC2 Xml string(s) created from a serialized ECSchema. |
schemaContext | ECSchemaXmlContext |
Returns - string[]
EC3.2 Xml ECSchema(s).
Defined in
- core/backend/src/SchemaUtils.ts Line 20
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.