insert MethodStatic

Insert a SheetIndex and a SheetIndexModel that sub-models it.

insert(iModelDb: IModelDb, parentSubjectId: string, name: string): string

@returns The Id of the newly inserted SheetIndexModel.

@throws IModelError if there is an insert problem.

Parameter Type Description
iModelDb IModelDb Insert into this iModel
parentSubjectId string The SheetIndex will be inserted as a child of this Subject element.
name string The name of the SheetIndex that the new SheetIndexModel will sub-model.

Returns - string

The Id of the newly inserted SheetIndexModel.

Defined in

Last Updated: 14 November, 2024