insert MethodStatic
Insert a DefinitionPartition and a DefinitionModel that sub-models it.
insert(iModelDb: IModelDb, parentSubjectId: string, name: string): string
@returns The Id of the newly inserted DefinitionModel.
@throws IModelError if there is an insert problem.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | Insert into this iModel |
parentSubjectId | string | The DefinitionPartition will be inserted as a child of this Subject element. |
name | string | The name of the DefinitionPartition that the new DefinitionModel will sub-model. |
Returns - string
The Id of the newly inserted DefinitionModel.
Defined in
- core/backend/src/Model.ts Line 511
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.