TxnChangedEntities Interface
Describes a set of Elements or Models that changed as part of a transaction.
@see onElementsChanged and onModelsChanged.
Properties
Name | Type | Description | |
---|---|---|---|
deletes Readonly | EntityIdAndClassIdIterable | The entities that were deleted by the transaction. | |
inserts Readonly | EntityIdAndClassIdIterable | The entities that were inserted by the transaction. | |
updates Readonly | EntityIdAndClassIdIterable | The entities that were modified by the transaction, including any Elements for which one of their ElementAspects was changed. |
Defined in
- core/backend/src/TxnManager.ts Line 43
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.