insert MethodStatic
Insert a new SubCategory
insert(iModelDb: IModelDb, parentCategoryId: string, name: string, appearance: SubCategoryAppearance | SubCategoryAppearance.Props): string
@returns The Id of the newly inserted SubCategory element.
@throws IModelError if unable to insert the element.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | Insert into this iModel |
parentCategoryId | string | Insert the new SubCategory as a child of this Category |
name | string | The name of the SubCategory |
appearance | SubCategoryAppearance | SubCategoryAppearance.Props | The appearance settings to use for this SubCategory |
Returns - string
The Id of the newly inserted SubCategory element.
Defined in
- core/backend/src/Category.ts Line 91
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.