create MethodStatic
Create a new SubCategory
create(iModelDb: IModelDb, parentCategoryId: string, name: string, appearance: SubCategoryAppearance | SubCategoryAppearance.Props): SubCategory
@returns The newly constructed SubCategory element.
@throws IModelError if unable to create the element.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The iModel |
parentCategoryId | string | Create the new SubCategory as a child of this Category |
name | string | The name of the SubCategory |
appearance | SubCategoryAppearance | SubCategoryAppearance.Props | The appearance settings to use for this SubCategory |
Returns - SubCategory
The newly constructed SubCategory element.
Defined in
- core/backend/src/Category.ts Line 68
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.