insert MethodStatic
Insert a new SpatialCategory
insert(iModelDb: IModelDb, definitionModelId: string, name: string, defaultAppearance: SubCategoryAppearance | SubCategoryAppearance.Props): string
@returns The Id of the newly inserted SpatialCategory element.
@throws IModelError if unable to insert the element.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | Insert into this iModel |
definitionModelId | string | Insert the new SpatialCategory into this DefinitionModel |
name | string | The name of the SpatialCategory |
defaultAppearance | SubCategoryAppearance | SubCategoryAppearance.Props | The appearance settings to use for the default SubCategory of this SpatialCategory |
Returns - string
The Id of the newly inserted SpatialCategory element.
Defined in
- core/backend/src/Category.ts Line 247
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.