openFile MethodStatic
Open a read-only iModel snapshot.
openFile(path: string, opts?: SnapshotDbOpenArgs): SnapshotDb
@see close
@throws IModelError If the file is not found or is not a valid snapshot.
Parameter | Type | Description |
---|---|---|
path | string | the full path of the snapshot iModel file to open. |
opts | SnapshotDbOpenArgs |
Returns - SnapshotDb
Defined in
- core/backend/src/IModelDb.ts Line 3272
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.