tryPrepareStatement Method
Deprecated in 4.11. Use IModelDb.createQueryReader or ECDb.createQueryReader to query.
IModelDb.createQueryReader is an asynchronous API. If you encounter a use case that cannot be converted to async, please report an issue at https://github.com/iTwin/itwinjs-core/issues. Mean while use IModelDb.withPreparedStatement for synchronous API calls where conversion to async is not possible.
Prepare an ECSQL statement.
tryPrepareStatement(sql: string): undefined | ECSqlStatement
@returns undefined
if there is a problem preparing the statement.
Parameter | Type | Description |
---|---|---|
sql | string | The ECSQL statement to prepare |
Returns - undefined | ECSqlStatement
undefined
if there is a problem preparing the statement.
Defined in
- core/backend/src/IModelDb.ts Line 1079
Last Updated: 17 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.