queryRowCount Method
Deprecated in 3.7. Count the number of results using count(*)
where the original query is a subquery instead. E.g., SELECT count(*) FROM (<query-whose-rows-to-count>)
.
Compute number of rows that would be returned by the ECSQL.
See also:
queryRowCount(ecsql: string, params?: QueryBinder): Promise<number>
@returns Return row count.
@throws IModelError If the statement is invalid
Parameter | Type | Description |
---|---|---|
ecsql | string | The ECSQL statement to execute |
params | QueryBinder | The values to bind to the parameters (if the ECSQL has any). See "iTwin.js Types used in ECSQL Parameter Bindings" for details. |
Returns - Promise
Return row count.
Defined in
- core/backend/src/IModelDb.ts Line 522
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.