IModelHostConfiguration Class
Configuration of core-backend.
Implements
Methods
Name | Description | |
---|---|---|
constructor(): IModelHostConfiguration |
Properties
Name | Type | Description | |
---|---|---|---|
appAssetsDir | string | undefined | The directory where application assets are found. | |
authorizationClient | AuthorizationClient | undefined | The AuthorizationClient used to obtain AccessTokens. | |
cacheDir | string | undefined | Root of the directory holding all the files that iTwin.js caches | |
compressCachedTiles | boolean | undefined | Whether to compress cached tiles. | |
defaultLogTileLoadTimeThreshold Static | number | ||
defaultLogTileSizeThreshold Static | number | ||
defaultTileRequestTimeout Static | number | ||
restrictTileUrlsByClientIp | boolean | undefined | ||
tileCacheAzureCredentials | AzureBlobStorageCredentials | undefined | ||
workspace | WorkspaceOpts | undefined |
Defined in
- core/backend/src/IModelHost.ts Line 204
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.