FileNameResolver Class
Deprecated in 4.10. When opening a snapshot by file name, ensure to pass already resolved path. Using a key to open a snapshot is now deprecated.
Extend this class to provide custom file name resolution behavior.
@note Only tryResolveKey
and/or tryResolveFileName
need to be overridden as the implementations of resolveKey
and resolveFileName
work for most purposes.
Methods
Name | Description | |
---|---|---|
constructor(): FileNameResolver | ||
resolveFileName(inFileName: string): string | Resolve the input file name, which may be a partial name, into a full path file name. | |
resolveKey(fileKey: string): string | Resolve a file name from the specified key. | |
tryResolveFileName(inFileName: string): undefined | string | Resolve the input file name, which may be a partial name, into a full path file name. | |
tryResolveKey(_fileKey: string): undefined | string | Resolve a file name from the specified key. |
Defined in
- core/backend/src/IModelHost.ts Line 698
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.