ExportPartInfo Interface
Info provided to ExportPartFunction about graphics. See IModelDb.exportPartGraphics
Properties
Name | Type | Description | |
---|---|---|---|
color | number | The color and transparency for these graphics | |
geometryClass | GeometryClass | GeometryClass for these graphics | |
materialId | string | undefined | If defined, ID for the RenderMaterialElement for these graphics | |
mesh | ExportGraphicsMesh | The mesh for these graphics | |
textureId | string | undefined | If defined, ID for the Texture for these graphics |
Defined in
- core/backend/src/ExportGraphics.ts Line 181
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.