ExportGraphicsOptions Interface
Parameters for IModelDb.exportGraphics
Properties
Name | Type | Description | |
---|---|---|---|
angleTol | number | undefined | Max angle difference in radians for approximated face, see StrokeOptions. | |
chordTol | number | undefined | Max distance from a face to the original geometry, see StrokeOptions. | |
decimationTol | number | undefined | Max distance between mesh vertices for them to be collapsed. | |
elementIdArray | Id64Array | The source elements for the exported graphics | |
maxEdgeLength | number | undefined | Max length of any edge in generated faces, see StrokeOptions. | |
minBRepFeatureSize | number | undefined | BRep features with bounding boxes smaller than this size will not generate graphics. | |
minLineStyleComponentSize | number | undefined | The longest dimension of a line style's largest component must be at least this size in order for | |
onGraphics | ExportGraphicsFunction | A function to call for each unique element ID, color and texture combination | |
onLineGraphics | ExportLinesFunction | undefined | An optional function to call if line graphics are desired. | |
partInstanceArray | ExportPartInstanceInfo[] | undefined | If supplied, any references to GeometryPart elements found will be |
Defined in
- core/backend/src/ExportGraphics.ts Line 130
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.