ExportPartInstanceInfo Interface
Information about references to GeometryPart elements found during a call to IModelDb.exportGraphics. See IModelDb.exportPartGraphics for the intended use case.
Properties
Name | Type | Description | |
---|---|---|---|
displayProps | ExportPartDisplayInfo | The base display properties when the GeometryPart was referenced. | |
partId | string | ID for the GeometryPart | |
partInstanceId | string | ID for the element that contained the reference to the GeometryPart | |
transform | Float64Array | undefined | A row-major storage 4x3 transform for this instance. |
Defined in
- core/backend/src/ExportGraphics.ts Line 108
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.