create MethodStatic
Create a TemplateRecipe3d
create(iModelDb: IModelDb, definitionModelId: string, name: string, isPrivate?: boolean): TemplateRecipe3d
@returns The newly constructed TemplateRecipe3d
@throws IModelError if there is a problem creating the TemplateRecipe3d
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The IModelDb |
definitionModelId | string | The Id of the DefinitionModel that contains this TemplateRecipe3d element. |
name | string | The name (Code.value) of the TemplateRecipe3d |
isPrivate | boolean |
Returns - TemplateRecipe3d
The newly constructed TemplateRecipe3d
Defined in
- core/backend/src/Element.ts Line 1146
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.