insert MethodStatic
Insert a TemplateRecipe2d and a DrawingModel (sub-model) that will contain the 2d template elements.
insert(iModelDb: IModelDb, definitionModelId: string, name: string, isPrivate?: boolean): string
@returns The Id of the newly inserted TemplateRecipe2d and the PhysicalModel that sub-models it.
@throws IModelError if there is a problem inserting the TemplateRecipe2d or its sub-model.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The IModelDb |
definitionModelId | string | The Id of the DefinitionModel that contains this TemplateRecipe2d element. |
name | string | The name (Code.value) of the TemplateRecipe2d |
isPrivate | boolean |
Returns - string
The Id of the newly inserted TemplateRecipe2d and the PhysicalModel that sub-models it.
Defined in
- core/backend/src/Element.ts Line 1233
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.