insert MethodStatic
Insert a Subject
insert(iModelDb: IModelDb, parentSubjectId: string, name: string, description?: string): string
@returns The Id of the newly inserted Subject
@throws IModelError if there is a problem inserting the Subject
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | Insert into this IModelDb |
parentSubjectId | string | The new Subject will be inserted as a child of this Subject |
name | string | The name (codeValue) of the Subject |
description | string | The optional description of the Subject |
Returns - string
The Id of the newly inserted Subject
Defined in
- core/backend/src/Element.ts Line 751
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.