create MethodStatic
Create a Subject
create(iModelDb: IModelDb, parentSubjectId: string, name: string, description?: string): Subject
@returns The newly constructed Subject
@throws IModelError if there is a problem creating the Subject
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The IModelDb |
parentSubjectId | string | The new Subject will be a child of this Subject |
name | string | The name (codeValue) of the Subject |
description | string | The optional description of the Subject |
Returns - Subject
The newly constructed Subject
Defined in
- core/backend/src/Element.ts Line 732
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.