insert MethodStatic

Insert a BisCore:GraphicalPartition3d and a Generic:GraphicalModel3d that sub-models it.

insert(iModelDb: IModelDb, parentSubjectId: string, name: string, isPlanProjection?: boolean): string

@returns The Id of the newly inserted GraphicalPartition3d and GraphicalModel3d (same value).

@throws IModelError if there is an insert problem.

Parameter Type Description
iModelDb IModelDb Insert into this iModel
parentSubjectId string The GraphicalPartition3d will be inserted as a child of this Subject element.
name string The name of the GraphicalPartition3d that the new Generic:GraphicalModel3d will sub-model.
isPlanProjection boolean Optional value (default is false) that indicates if the contents of this model are expected to be in an XY plane.

Returns - string

The Id of the newly inserted GraphicalPartition3d and GraphicalModel3d (same value).

Defined in

Last Updated: 14 November, 2024