insert MethodStatic
Insert a FunctionalPartition and a FunctionalModel that breaks it down.
insert(iModelDb: IModelDb, parentSubjectId: string, name: string): string
@returns The Id of the newly inserted FunctionalPartition and FunctionalModel (same value).
@throws IModelError if there is an insert problem.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | Insert into this iModel |
parentSubjectId | string | The FunctionalPartition will be inserted as a child of this Subject element. |
name | string | The name of the FunctionalPartition that the new FunctionalModel will break down. |
Returns - string
The Id of the newly inserted FunctionalPartition and FunctionalModel (same value).
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.