ElementSubTreeDeleter Class
Performs a breadth-first search to visit elements in top-down order. When the supplied filter function chooses an element, ElementTreeDeleter is used to delete it and its sub-tree.
Extends
- ElementTreeTopDown
Methods
Name | Description | |
---|---|---|
constructor(iModel: IModelDb, shouldPruneCb: ElementSubTreeDeleteFilter): ElementSubTreeDeleter | Construct an ElementSubTreeDeleter. | |
deleteNormalElementSubTrees(topElement: string, scope?: ElementTreeWalkerScope): void | Traverses the tree of elements beginning with the top element, and deletes all selected sub-trees. | |
deleteSpecialElementSubTrees(): void | Delete all special elements and their sub-trees that were found in the course of processing. | |
prune(elementId: string, scope: ElementTreeWalkerScope): void Protected | ||
shouldPrune(elementId: string, scope: ElementTreeWalkerScope): boolean Protected | Should the search not recurse into this sub-tree? |
Inherited methods
Name | Inherited from | Description |
---|---|---|
processElementTree(element: string, scope: ElementTreeWalkerScope): void Protected Inherited | ElementTreeTopDown |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_iModel Protected Inherited | IModelDb | ElementTreeTopDown |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.