insert MethodStatic
Insert a Drawing element and a DrawingModel that breaks it down.
insert(iModelDb: IModelDb, documentListModelId: string, name: string): string
@returns The Id of the newly inserted Drawing element and the DrawingModel that breaks it down (same value).
@throws IModelError if unable to insert the element.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | Insert into this iModel |
documentListModelId | string | Insert the new Drawing into this DocumentListModel |
name | string | The name of the Drawing. |
Returns - string
The Id of the newly inserted Drawing element and the DrawingModel that breaks it down (same value).
Defined in
- core/backend/src/Element.ts Line 796
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.