create MethodStatic
Create a DefinitionContainer
create(iModelDb: IModelDb, definitionModelId: string, code: Code, isPrivate?: boolean): DefinitionContainer
@returns The newly constructed DefinitionContainer
@note There is not a predefined CodeSpec for DefinitionContainer elements, so it is the responsibility of the domain or application to create one.
@throws IModelError if there is a problem creating the DefinitionContainer
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The IModelDb |
definitionModelId | string | The Id of the DefinitionModel that will contain this DefinitionContainer element. |
code | Code | The Code for this DefinitionContainer. |
isPrivate | boolean | The optional hint, that if true means it should not be displayed in the UI. |
Returns - DefinitionContainer
The newly constructed DefinitionContainer
Defined in
- core/backend/src/Element.ts Line 992
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.