produceTextAnnotationGeometry Function

Produce a geometric representation of a text annotation, with the annotation's anchor point at the origin. The result can be supplied to GeometryStreamBuilder.appendTextBlock.

produceTextAnnotationGeometry(args: ProduceTextAnnotationGeometryArgs): TextBlockGeometryProps

@see setAnnotation and setAnnotation to update the annotation, geometry, and placement of an annotation element.

Parameter Type Description
args ProduceTextAnnotationGeometryArgs  

Returns - TextBlockGeometryProps

Defined in

Last Updated: 06 September, 2024