setAnnotation Method
Change the textual content, updating the element's geometry and placement accordingly.
setAnnotation(annotation: TextAnnotation, subCategory?: string): boolean
@see getAnnotation to extract the current annotation.
@returns true if the annotation was successfully updated.
Parameter | Type | Description |
---|---|---|
annotation | TextAnnotation | The new annotation |
subCategory | string | If specified, the subcategory on which to define the geometry; otherwise, the default subcategory of the element's category is used. |
Returns - boolean
true if the annotation was successfully updated.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.