ComputeGraphemeOffsetsArgs Interface

Arguments supplied to computeGraphemeOffsets.

Extends

Properties

Name Type Description
graphemeCharIndexes number[] An array of starting character indexes for each grapheme.  
paragraphIndex number The index of the Paragraph in the text block that contains the run layout result text.  
runLayoutResult RunLayoutResult The run layout result for which grapheme ranges will be computed.  

Inherited properties

Name Type Inherited from Description
iModel Inherited IModelDb LayoutTextBlockArgs The iModel from which to obtain fonts and TextStyles when laying out glyphs.
textBlock Inherited TextBlock LayoutTextBlockArgs The text block whose extents are to be computed.

Defined in

Last Updated: 14 November, 2024