PartialECChangeUnifier Class
Combine partial changed instance into single instance. Partial changes is per table and a single instance can span multiple tables.
Methods
Name | Description | |
---|---|---|
constructor(): PartialECChangeUnifier | ||
appendFrom(adaptor: ChangesetECAdaptor): void | Append partial changes which will be combine using there instance key. | |
stripMetaData(): void | Delete $meta from all the instances. |
Properties
Name | Type | Description | |
---|---|---|---|
instances Accessor ReadOnly | IterableIterator<ChangedECInstance, any, any> | Returns complete EC change instances. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.