getById Method
Look up a CodeSpec by Id. The CodeSpec will be loaded from the database if necessary.
getById(codeSpecId: string): CodeSpec
@returns The CodeSpec with the specified Id
@throws IModelError if the Id is invalid or if no CodeSpec with that Id could be found.
Parameter | Type | Description |
---|---|---|
codeSpecId | string | The Id of the CodeSpec to load |
Returns - CodeSpec
The CodeSpec with the specified Id
Defined in
- core/backend/src/CodeSpecs.ts Line 49
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.