CodeSpecs Class
Manages CodeSpecs within an IModelDb
Methods
Name | Description | |
---|---|---|
constructor(imodel: IModelDb): CodeSpecs | ||
getById(codeSpecId: string): CodeSpec | Look up a CodeSpec by Id. | |
getByName(name: string): CodeSpec | Look up a CodeSpec by name. | |
hasId(codeSpecId: string): boolean | Returns true if the IModelDb has a CodeSpec of the specified Id. | |
hasName(name: string): boolean | Returns true if the IModelDb has a CodeSpec of the specified name. | |
insert(codeSpec: CodeSpec): string | Add a new CodeSpec to the iModel. | |
insert(name: string, properties: CodeSpecProperties | CodeScopeSpec.Type): string | Add a new CodeSpec to the IModelDb. | |
load(id: string): CodeSpec | Load a CodeSpec from the iModel | |
queryId(name: string): string | Look up the Id of the CodeSpec with the specified name. | |
updateProperties(codeSpec: CodeSpec): void | Update the Json properties of an existing CodeSpec. |
Defined in
- core/backend/src/CodeSpecs.ts Line 17
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.