ShortDateTypeConverter Class
Short Date Type Converter.
Extends
Methods
Name | Description | |
---|---|---|
constructor(): ShortDateTypeConverter | ||
getTimeFormat(): TimeFormat Protected |
Inherited methods
Name | Inherited from | Description |
---|---|---|
convertFromString(value: string): undefined | Date | DateTimeTypeConverterBase | Converts a string to a primitive value |
convertFromStringToPropertyValue(value: string, propertyRecord?: PropertyRecord): Promise<PropertyValue> | DateTimeTypeConverterBase | Converts a string with a property record to a property value |
convertFromStringWithOptions(value: string, options?: [key: string]: any): undefined | ConvertedPrimitives.Value | Promise<Value | undefined> | DateTimeTypeConverterBase |
convertPropertyToString(propertyDescription: PropertyDescription, value?: Primitives.Value): string | Promise<string> | DateTimeTypeConverterBase | Converts a value associated with a property description to a string |
convertToString(value?: Primitives.Value): string | DateTimeTypeConverterBase | Converts a primitive value to a string |
convertToStringWithOptions(value?: Primitives.Value, options?: [key: string]: any): string | Promise<string> | DateTimeTypeConverterBase | Default implementation just calls convertToString with no options |
isEqualTo(valueA: Date, valueB: Date): boolean | DateTimeTypeConverterBase | Determines if two primitive values are equal |
isGreaterThan(a: Date, b: Date): boolean | DateTimeTypeConverterBase | Determines if a primitive values is greater than another primitive value |
isGreaterThanOrEqualTo(a: Date, b: Date): boolean | DateTimeTypeConverterBase | Determines if a primitive values is greater than or equal to another primitive value |
isLessThan(a: Date, b: Date): boolean | DateTimeTypeConverterBase | Determines if a primitive values is less than another primitive value |
isLessThanOrEqualTo(a: Date, b: Date): boolean | DateTimeTypeConverterBase | Determines if a primitive values is less than or equal to another primitive value |
isNotEqualTo(valueA: Date, valueB: Date): boolean | DateTimeTypeConverterBase | Determines if two primitive values are not equal |
isNotNull(value: Primitives.Value): boolean | DateTimeTypeConverterBase | Determines if a primitive value is not null or not undefined |
isNull(value: Primitives.Value): boolean | DateTimeTypeConverterBase | Determines if a primitive value is null or undefined |
sortCompare(valueA: Date, valueB: Date, _ignoreCase?: boolean): number | DateTimeTypeConverterBase | Sort function for two primitive values |
isAlternateDateFormats(type: AlternateDateFormats): boolean Static | DateTimeTypeConverterBase | |
isValidTimeDisplay(type: TimeDisplay): boolean Static | DateTimeTypeConverterBase |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
isBooleanType Accessor ReadOnly | boolean | DateTimeTypeConverterBase | Determines if the converter is for a boolean type |
isLessGreaterType Accessor ReadOnly | boolean | DateTimeTypeConverterBase | Determines if the converter is for a numeric type |
isNullableType Accessor ReadOnly | boolean | DateTimeTypeConverterBase | Determines if the converter is for a nullable type |
isStringType Accessor ReadOnly | boolean | DateTimeTypeConverterBase | Determines if the converter is for a string type |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.