FloatTypeConverter Class
Float Type Converter.
Extends
Methods
Name | Description | |
---|---|---|
constructor(): FloatTypeConverter | ||
convertFromString(value: string): undefined | number | Converts a string to a primitive value | |
convertToString(value?: Primitives.Float): string | Converts a primitive value to a string |
Inherited methods
Name | Inherited from | Description |
---|---|---|
convertFromStringToPropertyValue(value: string, propertyRecord?: PropertyRecord): Promise<PropertyValue> | NumericTypeConverterBase | Converts a string with a property record to a property value |
convertFromStringWithOptions(value: string, _options?: [key: string]: any): undefined | ConvertedPrimitives.Value | Promise<Value | undefined> | NumericTypeConverterBase |
convertPropertyToString(propertyDescription: PropertyDescription, value?: Primitives.Value): string | Promise<string> | NumericTypeConverterBase | Converts a value associated with a property description to a string |
convertToStringWithOptions(value?: Primitives.Value, _options?: [key: string]: any): string | Promise<string> | NumericTypeConverterBase | Default implementation just calls convertToString with no options |
isEqualTo(valueA: Primitives.Value, valueB: Primitives.Value): boolean | NumericTypeConverterBase | Determines if two primitive values are equal |
isGreaterThan(a: Primitives.Numeric, b: Primitives.Numeric): boolean | NumericTypeConverterBase | Determines if a primitive values is greater than another primitive value |
isGreaterThanOrEqualTo(a: Primitives.Numeric, b: Primitives.Numeric): boolean | NumericTypeConverterBase | Determines if a primitive values is greater than or equal to another primitive value |
isLessThan(a: Primitives.Numeric, b: Primitives.Numeric): boolean | NumericTypeConverterBase | Determines if a primitive values is less than another primitive value |
isLessThanOrEqualTo(a: Primitives.Numeric, b: Primitives.Numeric): boolean | NumericTypeConverterBase | Determines if a primitive values is less than or equal to another primitive value |
isNotEqualTo(valueA: Primitives.Value, valueB: Primitives.Value): boolean | NumericTypeConverterBase | Determines if two primitive values are not equal |
isNotNull(value: Primitives.Value): boolean | NumericTypeConverterBase | Determines if a primitive value is not null or not undefined |
isNull(value: Primitives.Value): boolean | NumericTypeConverterBase | Determines if a primitive value is null or undefined |
sortCompare(a: Primitives.Numeric, b: Primitives.Numeric, _ignoreCase?: boolean): number | NumericTypeConverterBase | Sort function for two primitive values |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
isBooleanType Accessor ReadOnly | boolean | NumericTypeConverterBase | Determines if the converter is for a boolean type |
isLessGreaterType Accessor ReadOnly | boolean | NumericTypeConverterBase | Determines if the converter is for a numeric type |
isNullableType Accessor ReadOnly | boolean | NumericTypeConverterBase | Determines if the converter is for a nullable type |
isStringType Accessor ReadOnly | boolean | NumericTypeConverterBase | Determines if the converter is for a string type |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.