HighlightingEngine Class
Tree highlighting engine
Methods
Name | Description | |
---|---|---|
constructor(props: HighlightableTreeProps): HighlightingEngine | ||
createRenderProps(node: { id?: string }): HighlightableTreeNodeProps | ||
getActiveMatchIndex(node: { id?: string }): undefined | number | ||
isNodeActive(node: { id?: string }): undefined | boolean | ||
renderNodeLabel(text: string, props: HighlightableTreeNodeProps): React.ReactNode Static |
Properties
Name | Type | Description | |
---|---|---|---|
ACTIVE_CLASS_NAME Static Readonly | "components-activehighlight" |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.