AbstractTreeNodeLoader Class
Abstract node loader implementation which loads nodes into provided model source.
Extended by
Implements
Methods
Name | Description | |
---|---|---|
constructor(modelSource: TreeModelSource): AbstractTreeNodeLoader Protected | ||
load(parent: TreeModelNode | TreeModelRootNode, childIndex: number): Observable<LoadedNodeHierarchy> Protected Abstract | An abstract method to load a node at the specific index for the specified parent. | |
loadNode(parent: TreeModelNode | TreeModelRootNode, childIndex: number): Observable<TreeNodeLoadResult> | Do not override this method. | |
updateModel(loadedHierarchy: LoadedNodeHierarchy): void Protected | A method that's called when load loads some nodes and we need to put them into model source. |
Properties
Name | Type | Description | |
---|---|---|---|
modelSource Accessor ReadOnly | TreeModelSource |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.