VirtualizedPropertyGridProps Interface
Properties for VirtualizedPropertyGrid React component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
dataProvider | IPropertyDataProvider | Property data provider used by the property grid | |
eventHandler | IPropertyGridEventHandler | Handler of the events raised from the property grid | |
height | number | Height of the property grid component. | |
highlight | PropertyGridContentHighlightProps | undefined | Properties for highlighting property data in the grid. | |
model | IPropertyGridModel | Property grid view model that defines what needs to be rendered | |
propertyCategoryRendererManager | PropertyCategoryRendererManager | undefined | Custom property category renderer manager. | |
width | number | Width of the property grid component. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
actionButtonRenderers | ActionButtonRenderer[] | undefined | CommonPropertyGridProps | Array of action button renderers. |
actionButtonWidth | number | undefined | CommonPropertyGridProps | Fixed action button column width |
className | string | undefined | CommonPropertyGridProps | Custom CSS class name |
horizontalOrientationMinWidth | number | undefined | CommonPropertyGridProps | The minimum width before the auto-switch to Vertical when the width is too narrow. |
isOrientationFixed | boolean | undefined | CommonPropertyGridProps | Indicates whether the orientation is fixed and does not auto-switch to Vertical when the width is too narrow. |
isPropertyEditingEnabled | boolean | undefined | CommonPropertyGridProps | Enables/disables property editing |
isPropertyHoverEnabled | boolean | undefined | CommonPropertyGridProps | Enables/disables property hovering effect |
isPropertySelectionEnabled | boolean | undefined | CommonPropertyGridProps | Enables/disables property selection |
isPropertySelectionOnRightClickEnabled | boolean | undefined | CommonPropertyGridProps | Enables/disables property selection with right click |
itemId | string | undefined | CommonPropertyGridProps | Optional unique identifier for item. |
minLabelWidth | number | undefined | CommonPropertyGridProps | Minimum allowed label column width, after which resizing stops |
minValueWidth | number | undefined | CommonPropertyGridProps | Minimum allowed value column width, after which resizing stops |
onPropertyContextMenu | (args: PropertyGridContextMenuArgs) => void | undefined | CommonPropertyGridProps | Called to show a context menu when properties are right-clicked |
onPropertyEditing | (args: PropertyEditingArgs, category: PropertyCategory) => void | undefined | CommonPropertyGridProps | Callback for when properties are being edited |
onPropertySelectionChanged | (property: PropertyRecord) => void | undefined | CommonPropertyGridProps | Callback to property selection |
onPropertyUpdated | (args: PropertyUpdatedArgs, category: PropertyCategory) => Promise<boolean> | undefined | CommonPropertyGridProps | Callback for when properties are updated |
orientation | Orientation | undefined | CommonPropertyGridProps | Grid orientation. |
propertyValueRendererManager | PropertyValueRendererManager | undefined | CommonPropertyGridProps | Custom property value renderer manager |
style | React.CSSProperties | undefined | CommonPropertyGridProps | Custom CSS style properties |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.