CommonPropertyGridProps Interface
Common Property Grid Props to be used by Property Grid Variants
Extends
Properties
Name | Type | Description | |
---|---|---|---|
actionButtonRenderers | ActionButtonRenderer[] | undefined | Array of action button renderers. | |
actionButtonWidth | number | undefined | Fixed action button column width | |
horizontalOrientationMinWidth | number | undefined | The minimum width before the auto-switch to Vertical when the width is too narrow. | |
isOrientationFixed | boolean | undefined | Indicates whether the orientation is fixed and does not auto-switch to Vertical when the width is too narrow. | |
isPropertyEditingEnabled | boolean | undefined | Enables/disables property editing | |
isPropertyHoverEnabled | boolean | undefined | Enables/disables property hovering effect | |
isPropertySelectionEnabled | boolean | undefined | Enables/disables property selection | |
isPropertySelectionOnRightClickEnabled | boolean | undefined | Enables/disables property selection with right click | |
minLabelWidth | number | undefined | Minimum allowed label column width, after which resizing stops | |
minValueWidth | number | undefined | Minimum allowed value column width, after which resizing stops | |
onPropertyContextMenu | (args: PropertyGridContextMenuArgs) => void | undefined | Called to show a context menu when properties are right-clicked | |
onPropertyEditing | (args: PropertyEditingArgs, category: PropertyCategory) => void | undefined | Callback for when properties are being edited | |
onPropertySelectionChanged | (property: PropertyRecord) => void | undefined | Callback to property selection | |
onPropertyUpdated | (args: PropertyUpdatedArgs, category: PropertyCategory) => Promise<boolean> | undefined | Callback for when properties are updated | |
orientation | Orientation | undefined | Grid orientation. | |
propertyValueRendererManager | PropertyValueRendererManager | undefined | Custom property value renderer manager |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.