FavoritePropertiesRenderer Class

Renderer for Favorite Property List

Methods

Name Description
constructor(): FavoritePropertiesRenderer    
hasFavorites(propertyData: PropertyData): boolean Evaluates if a PropertyData contain Favorite records.  
renderFavorites(propertyData: PropertyData, orientation?: Orientation): string | HTMLElement Allow creating an HTMLElement containing the <FavoritePropertyList /> component so it can be added outside of a React component (showCard is the main expected use)  
renderFavorites(propertyData: PropertyData, orientation?: Orientation, _createRoot?: CreateRoot): string | HTMLElement Allow creating an HTMLElement containing the <FavoritePropertyList /> component so it can be added outside of a React component (showCard is the main expected use) Deprecated  

Defined in

Last Updated: 17 December, 2024