UiItemsManager Class
Controls registering of UiItemsProviders and calls the provider's methods when populating different parts of the User Interface.
Methods
Name | Description | |
---|---|---|
constructor(): UiItemsManager | ||
getBackstageItems(): ReadonlyArray<ProviderItem<BackstageItem>> Static | Returns registered backstage items. | |
getStatusBarItems(stageId: string, stageUsage: string): ReadonlyArray<ProviderItem<StatusBarItem>> Static | Returns registered status bar items that match the specified frontstage id and usage. | |
getToolbarButtonItems(stageId: string, stageUsage: string, usage: ToolbarUsage, orientation: ToolbarOrientation): ReadonlyArray<ProviderItem<ToolbarItem>> Static | Returns registered toolbar items configured for the standard layout that match the specified frontstage id and usage. | |
getToolbarItems(stageId: string, stageUsage: string): ReadonlyArray<ProviderItem<ToolbarItem>> Static | Returns registered toolbar items that match the specified frontstage id and usage. | |
getUiItemsProvider(providerId: string): undefined | UiItemsProvider Static | Retrieves a previously loaded UiItemsProvider. | |
getWidgets(stageId: string, stageUsage: string): ReadonlyArray<ProviderItem<Widget>> Static | Returns registered widgets that match the specified frontstage id and usage. | |
getWidgets(stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection): ReadonlyArray<ProviderItem<Widget>> Static | Returns registered widgets configured for the standard layout that match the specified frontstage id and usage. | |
register(uiProvider: UiItemsProvider, overrides?: UiItemsProviderOverrides): void Static | Registers an UiItemsProvider. | |
unregister(providerId: string): void Static | Unregisters a specific UiItemsProvider. |
Properties
Name | Type | Description | |
---|---|---|---|
hasRegisteredProviders Accessor Static ReadOnly | boolean | Return true if there is any registered UiProvider. | |
onUiProviderRegisteredEvent Accessor Static ReadOnly | BeUiEvent<UiItemsProviderRegisteredEventArgs> | Event raised any time a UiProvider is registered or unregistered. | |
registeredProviderIds Accessor Static ReadOnly | string[] | Return number of registered UiProvider. |
Defined in
Last Updated: 14 March, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.