SelectionContextToolDefinitions Class
Deprecated in 4.15.0. Use ToolbarItems instead.
Utility Class that provides definitions for tools dependent on current selection. These definitions can be used to populate toolbars.
Methods
Name | Description | |
---|---|---|
constructor(): SelectionContextToolDefinitions |
Properties
Name | Type | Description | |
---|---|---|---|
clearHideIsolateEmphasizeElementsItemDef Accessor Static ReadOnly | CommandItemDef | ||
emphasizeElementsItemDef Accessor Static ReadOnly | CommandItemDef | ||
hideCategoriesInSelectionItemDef Accessor Static ReadOnly | CommandItemDef | ||
hideElementsItemDef Accessor Static ReadOnly | CommandItemDef | ||
hideModelsInSelectionItemDef Accessor Static ReadOnly | CommandItemDef | ||
hideSectionToolGroup Accessor Static ReadOnly | GroupItemDef | ||
isolateCategoriesInSelectionItemDef Accessor Static ReadOnly | CommandItemDef | ||
isolateElementsItemDef Accessor Static ReadOnly | CommandItemDef | ||
isolateModelsInSelectionItemDef Accessor Static ReadOnly | CommandItemDef | ||
isolateSelectionToolGroup Accessor Static ReadOnly | GroupItemDef |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.