ToolbarCustomItem Interface
Describes the data needed to insert a custom button into a toolbar.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
icon Readonly | IconSpec | undefined | Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. | Deprecated |
label Readonly | string | ConditionalStringValue | label, shown as tool tip on group button or a group button label in a group panel. | |
panelContent Readonly | React.ReactNode | undefined | defines the content to display in popup panel |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
badge Readonly | BadgeType | undefined | CommonToolbarItem | Describes badge. |
badgeKind Readonly | BadgeKind | undefined | CommonToolbarItem | Specifies the kind of badge, if any, to be rendered. |
description Readonly | string | ConditionalStringValue | CommonToolbarItem | Optional description |
groupPriority Readonly | number | undefined | CommonToolbarItem | Specifies the item's grouping value. |
iconNode Readonly | React.ReactNode | undefined | CommonToolbarItem | Icon of a toolbar item. |
id Readonly | string | CommonToolbarItem | Require uniqueId for the item. |
isActive Readonly | boolean | undefined | CommonToolbarItem | Defines if the item is active (shown with an active stripe/bar). |
isDisabled Readonly | boolean | ConditionalBooleanValue | CommonToolbarItem | Describes if the item is enabled or disabled. |
isHidden Readonly | boolean | ConditionalBooleanValue | CommonToolbarItem | Describes if the item is visible or hidden. |
itemPriority Readonly | number | CommonToolbarItem | Priority within a toolbar or group. |
layouts Readonly | ToolbarItemLayouts | undefined | CommonToolbarItem | Describes layout specific configuration of a toolbar item. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.