CommonToolbarItem Interface
Describes the data needed to insert a UI items into an existing set of UI items.
Properties
Name | Type | Description | |
---|---|---|---|
badge Readonly | BadgeType | undefined | Describes badge. | Deprecated |
badgeKind Readonly | BadgeKind | undefined | Specifies the kind of badge, if any, to be rendered. | |
description Readonly | string | ConditionalStringValue | Optional description | |
groupPriority Readonly | number | undefined | Specifies the item's grouping value. | |
iconNode Readonly | React.ReactNode | undefined | Icon of a toolbar item. | |
id Readonly | string | Require uniqueId for the item. | |
isActive Readonly | boolean | undefined | Defines if the item is active (shown with an active stripe/bar). | |
isDisabled Readonly | boolean | ConditionalBooleanValue | Describes if the item is enabled or disabled. | |
isHidden Readonly | boolean | ConditionalBooleanValue | Describes if the item is visible or hidden. | |
itemPriority Readonly | number | Priority within a toolbar or group. | |
layouts Readonly | ToolbarItemLayouts | undefined | Describes layout specific configuration of a toolbar item. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.