ToolbarActionItem Interface

Describes the data needed to insert an action button into a toolbar.

Extends

Properties

Name Type Description
execute Readonly () => void function to run when the button is pressed.  
icon Readonly IconSpec Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. Deprecated  
label Readonly string | ConditionalStringValue label, shown as tool tip on a button or an item label in a group.  
parentGroupItemId Readonly string | undefined Optional parent tool group to add the tool to.  

Inherited properties

Name Type Inherited from Description
badge Readonly BadgeType | undefined CommonToolbarItem Describes badge.
badgeKind Readonly BadgeKind | undefined CommonToolbarItem Specifies the kind of badge, if any, to be rendered.
description Readonly string | ConditionalStringValue CommonToolbarItem Optional description
groupPriority Readonly number | undefined CommonToolbarItem Specifies the item's grouping value.
iconNode Readonly React.ReactNode | undefined CommonToolbarItem Icon of a toolbar item.
id Readonly string CommonToolbarItem Require uniqueId for the item.
isActive Readonly boolean | undefined CommonToolbarItem Defines if the item is active (shown with an active stripe/bar).
isDisabled Readonly boolean | ConditionalBooleanValue CommonToolbarItem Describes if the item is enabled or disabled.
isHidden Readonly boolean | ConditionalBooleanValue CommonToolbarItem Describes if the item is visible or hidden.
itemPriority Readonly number CommonToolbarItem Priority within a toolbar or group.
layouts Readonly ToolbarItemLayouts | undefined CommonToolbarItem Describes layout specific configuration of a toolbar item.

Defined in

Last Updated: 14 November, 2024